
1 Introduction
The Freescale Embedded Software Libraries (FSLESL)
product has been designed to facilitate and speed up the
development of mainly motor control applications but they
can be used generally with digital embedded systems. The
migration from the former CodeWarrior 8.3 (and older)
compiler has brought some changes in the project structure
and its resource configuration.

This application note deals with the step-by-step guide how to
quickly and easily include the FSLESL into an empty project
and to reduce the necessary time of the user to study how to do
that.

The example in this application note uses the MC56F84789
part and the FSLESL installation path, C:\Freescale
\56800E_FSLESL_r2.01 is supposed. If the user has a
different installation path, use that path instead of the above-
mentioned.

For more information, visit http://www.freescale.com/fslesl.

2 New project
To be able to start working on an application, a new project
must be created. Follow the steps given below to create a new
project.

1. Launch the CodeWarrior Development Studio.
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2. Choose File > New > Bareboard Project so that the dialog "New Bareboard Project" appears.
3. Type a name of the project, for instance, MyProject01.
4. If the default location is not used, deselect the checkbox labeled “Use default location” and type the path where the

project folder is to be created; for instance, c:\CWProjects\MyProject01, and click Next. See Figure 1.

Figure 1. Project name and location
5. Expand the tree by clicking 56800/E (DSC) and MC56F84789. Select the Application option and click Next. See

Figure 2.
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Figure 2. Processor selection
6. Now, select the option of the connection to be used to download and debug the application. For this case, select the

option P&E USB MultiLink Universal[FX] / USB MultiLink and click Next. See Figure 3.
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Figure 3. Connection selection
7. Out of the options given, select the Simple Mixed Assembly and C language option to choose the language to be used

and click Finish. See Figure 4.

Figure 4. Language choice

The newly created project is now visible in the left hand part of the CodeWarrior Development Studio. See Figure 5.
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Figure 5. Project folder

3 Including FSLESL
To include the libraries into the project, the library files must be added first and their paths, properly set up. FSLESL contains
four libraries which can be added. This guide will show step-by-step addition of each of these libraries.

3.1 GFLIB reference addition
The inclusion of GFLIB will have the following steps.

1. Right-click the MyProject01 node in the left hand part or choose Project > Properties from the menu. A properties
dialog of the project will appear.

2. Expand the C/C++ General node and click Paths and Symbols. See Figure 6.
3. Click the Libraries tab in the right-hand side.
4. In the dialog which appears, look for the library file 56800E_GFLIB.lib, by clicking 'File system…' or just typing the

following path into the box: C:\Freescale\56800E_FSESL_r2.01\56800E_GFLIB_r2.0\56800E_GFLIB.lib and click
OK. Now, the library file is displayed in the table. See Figure 7.
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Figure 6. Project properties
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Figure 7. Projects libraries paths
5. Click the Library Paths tab and now it is necessary to add the library path. Click the 'Add…' button.
6. Similarly, look for the library path or just type C:\Freescale\56800E_FSESL_r2.01\56800E_GFLIB_r2.0\include, into

the box and click OK. Now, the folder will be displayed in the table. See Figure 8.

Figure 8. Projects libraries paths
7. Now, it is necessary to add the library path for the compiler. So on the left-hand side, expand the C/C++ Build node

and click Settings. See Figure 9.

Including FSLESL

Inclusion of DSC Freescale Embedded Software Libraries in CodeWarrior 10.2, Rev. 0, 9/2012

Freescale Semiconductor, Inc. 7



Figure 9. Project properties
8. In the tree of the right-hand part, choose DSC Compiler and select Access Paths.
9. In the first dialog Search User Paths (#include “…”), click the 'Add…' icon and a dialog will appear.

10. In this dialog, deselect the Relative To option and look for the library path or just type C:\Freescale
\56800E_FSESL_r2.01\56800E_GFLIB_r2.0\include, in the box and click OK. Now, the library path is added into the
first dialog. See Figure 10.

11. Click OK of the main dialog.
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Figure 10. DSC Compiler settings
12. Finally, it is necessary to add a reference of the library header file. In the project folder (left-hand part), right-click the

Project_Headers folder, choose 'Add files…' and select the file C:\Freescale
\56800E_FSESL_r2.01\56800E_GFLIB_r2.0\include\gflib.h. See Figure 11.

13. In the following dialog, select the "Link to files" option and deselect the "Create link location relative to" option and
click OK.

The final step is just typing the #include syntax in the code. The GFLIB library can be included into the main.c file. In
the left-hand dialog, open the Sources folder of the project and double-click the main.c file. After the main.c file opens
up, include the following line in the #include section:

#include "gflib.h"

Now, if the user clicks the Build icon (hammer), the project will be compiled without errors.
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Figure 11. Link header file

3.2 MCLIB reference addition
The inclusion of MCLIB will have the same steps.

1. Right-click the MyProject01 node in the left hand part or choose Project > Properties from the menu. A properties
dialog of the project will appear.

2. Expand the C/C++ General node and click Paths and Symbols.
3. Click the Libraries tab in the right-hand side.
4. In the dialog which appears, look for the library file 56800E_MCLIB.lib, by clicking 'File system…' or just typing the

following path into the box: C:\Freescale\56800E_FSESL_r2.01\56800E_MCLIB_r2.0\56800E_MCLIB.lib and click
OK. Now, the library file is displayed in the table.

5. Click the Library Paths tab and now it is necessary to add the library path. Click the 'Add…' button.
6. Similarly, look for the library path or just type C:\Freescale\56800E_FSESL_r2.01\56800E_MCLIB_r2.0\include, into

the box and click OK. Now, the folder will be displayed in the table.
7. Now, it is necessary to add the library path for the compiler. So on the left-hand side, expand the C/C++ Build node

and click Settings.
8. In the tree of the right-hand part, choose DSC Compiler and select Access Paths.
9. In the first dialog Search User Paths (#include “…”), click the 'Add…' icon and a dialog will appear.

10. In this dialog, deselect the Relative To option and look for the library path or just type C:\Freescale
\56800E_FSESL_r2.01\56800E_MCLIB_r2.0\include, in the box and click OK. Now, the library path is added into the
first dialog.

11. Click OK of the main dialog.
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12. Finally, it is necessary to add a reference of the library header file. In the project folder (left-hand part), right-click the
Project_Headers folder, choose 'Add files…' and select the file C:\Freescale
\56800E_FSESL_r2.01\56800E_MCLIB_r2.0\include\mclib.h.

13. In the following dialog, select the "Link to files" option and deselect the "Create link location relative to" option and
click OK.

The final step is just typing the #include syntax in the code. The MCLIB library can be included into the main.c file. In
the left-hand dialog, open the Sources folder of the project and double-click the main.c file. After the main.c file opens
up, include the following line in the #include section:

#include "mclib.h"

NOTE
Don’t forget that GFLIB must be included to be able to use MCLIB.

Now, if the user clicks the Build icon (hammer), the project will be compiled without errors.

3.3 GDFLIB reference addition
The inclusion of GDFLIB will have the same steps as of GFLIB.

1. Right-click the MyProject01 node in the left hand part or choose Project > Properties from the menu. A properties
dialog of the project will appear.

2. Expand the C/C++ General node and click Paths and Symbols.
3. Click the Libraries tab in the right-hand side.
4. In the dialog which appears, look for the library file 56800E_GDFLIB.lib, by clicking 'File system…' or just typing the

following path into the box: C:\Freescale\56800E_FSESL_r2.01\56800E_GDFLIB_r2.0\56800E_GDFLIB.lib and
click OK. Now, the library file is displayed in the table.

5. Click the Library Paths tab and now it is necessary to add the library path. Click the 'Add…' button.
6. Similarly, look for the library path or just type C:\Freescale\56800E_FSESL_r2.01\56800E_GDFLIB_r2.0\include, into

the box and click OK. Now, the folder will be displayed in the table.
7. Now, it is necessary to add the library path for the compiler. So on the left-hand side, expand the C/C++ Build node

and click Settings.
8. In the tree of the right-hand part, choose DSC Compiler and select Access Paths.
9. In the first dialog Search User Paths (#include “…”), click the 'Add…' icon and a dialog will appear.

10. In this dialog, deselect the Relative To option and look for the library path or just type C:\Freescale
\56800E_FSESL_r2.01\56800E_GDFLIB_r2.0\include, in the box and click OK. Now, the library path is added into
the first dialog.

11. Click OK of the main dialog.
12. Finally, it is necessary to add a reference of the library header file. In the project folder (left-hand part), right-click the

Project_Headers folder, choose 'Add files…' and select the file C:\Freescale
\56800E_FSESL_r2.01\56800E_GDFLIB_r2.0\include\gdflib.h.

13. In the following dialog, select the "Link to files" option and deselect the "Create link location relative to" option and
click OK.

The final step is just typing the #include syntax in the code. The GDFLIB library can be included into the main.c file.
In the left-hand dialog, open the Sources folder of the project and double-click the main.c file. After the main.c file
opens up, include the following line in the #include section:

#include "gdflib.h"

Now, if the user clicks the Build icon (hammer), the project will be compiled without errors.
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3.4 ACLIB reference addition
The inclusion of ACLIB will have the same steps as of GFLIB.

1. Right-click the MyProject01 node in the left hand part or choose Project > Properties from the menu. A properties
dialog of the project will appear.

2. Expand the C/C++ General node and click Paths and Symbols.
3. Click the Libraries tab in the right-hand side.
4. In the dialog which appears, look for the library file 56800E_ACLIB.lib, by clicking 'File system…' or just typing the

following path into the box: C:\Freescale\56800E_FSESL_r2.01\56800E_ACLIB_r2.0\56800E_ACLIB.lib and click
OK. Now, the library file is displayed in the table.

5. Click the Library Paths tab and now it is necessary to add the library path. Click the 'Add…' button.
6. Similarly, look for the library path or just type C:\Freescale\56800E_FSESL_r2.01\56800E_ACLIB_r2.0\include, into

the box and click OK. Now, the folder will be displayed in the table.
7. Now, it is necessary to add the library path for the compiler. So on the left-hand side, expand the C/C++ Build node

and click Settings.
8. In the tree of the right-hand part, choose DSC Compiler and select Access Paths.
9. In the first dialog Search User Paths (#include “…”), click the 'Add…' icon and a dialog will appear.

10. In this dialog, deselect the Relative To option and look for the library path or just type C:\Freescale
\56800E_FSESL_r2.01\56800E_ACLIB_r2.0\include, in the box and click OK. Now, the library path is added into the
first dialog.

11. Click OK of the main dialog.
12. Finally, it is necessary to add a reference of the library header file. In the project folder (left-hand part), right-click the

Project_Headers folder, choose 'Add files…' and select the file C:\Freescale
\56800E_FSESL_r2.01\56800E_ACLIB_r2.0\include\aclib.h.

13. In the following dialog, select the "Link to files" option and deselect the "Create link location relative to" option and
click OK.

The final step is just typing the #include syntax in the code. The ACLIB library can be included into the main.c file. In
the left-hand dialog, open the Sources folder of the project and double-click the main.c file. After the main.c file opens
up, include the following line in the #include section:

#include "aclib.h"

NOTE
Don’t forget that GFLIB and MCLIB must be included to be able to use ACLIB.

Now, if the user clicks the Build icon (hammer), the project will be compiled without errors.

4 Definitions and acronyms
CW CodeWarrior

FSLESL Freescale Embedded Software Libraries, the software tool
which can be downloaded from http://www.freescale.com/
fslesl

GFLIB General Functions Library

MCLIB Motor Control Library

GDFLIB General Digital Filters Library

ACLIB Advanced Control Library

DSC Digital Signal Controller

Motor control In this application note, it means a process which controls an
electrical motor such as BLDC PMSM, AC-induction or other.
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