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Chapter 1
Library

1.1 Introduction

1.1.1 Overview

This user's guide describes the Power Control Library (PCLIB) for the family of ARM Cortex M7 core-based microcontrollers. This
library contains optimized functions.

1.1.2 Data types

PCLIB supports several data types: (un)signed integer, fractional , and accumulator. The integer data types are useful for
general-purpose computation; they are familiar to the MPU and MCU programmers. The fractional data types enable powerful
numeric and digital-signal-processing algorithms to be implemented. The accumulator data type is a combination of both; that
means it has the integer and fractional portions.

The following list shows the integer types defined in the libraries:

* Unsigned 16-bit integer—<0 ; 65535> with the minimum resolution of 1

» Signed 16-bit integer—<-32768 ; 32767> with the minimum resolution of 1

* Unsigned 32-bit integer—<0 ; 4294967295> with the minimum resolution of 1

» Signed 32-bit integer—<-2147483648 ; 2147483647> with the minimum resolution of 1
The following list shows the fractional types defined in the libraries:

+ Fixed-point 16-bit fractional—<-1 ; 1 - 2-15> with the minimum resolution of 2-15

+ Fixed-point 32-bit fractional—<-1 : 1 - 231> with the minimum resolution of 2-31
The following list shows the accumulator types defined in the libraries:

+ Fixed-point 16-bit accumulator—<-256.0 ; 256.0 - 27> with the minimum resolution of 27

« Fixed-point 32-bit accumulator—<-65536.0 ; 65536.0 - 2-15> with the minimum resolution of 2-15

1.1.3 API definition

PCLIB uses the types mentioned in the previous section. To enable simple usage of the algorithms, their names use set prefixes
and postfixes to distinguish the functions' versions. See the following example:

f32Result = MLIB Mac F321ss(f32Accum, flé6Multl, fle6Mult2);

where the function is compiled from four parts:
* MLIB—this is the library prefix
* Mac—the function name—Multiply-Accumulate
* F32—the function output type

» Iss—the types of the function inputs; if all the inputs have the same type as the output, the inputs are
not marked

The input and output types are described in the following table:
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Table 1. Input/output types

Type Output Input
frac16_t F16 ]
frac32_t F32 I
acc32_t A32 a

1.1.4 Supported compilers

PCLIB for the ARM Cortex M7 core is written in C language or assembly language with C-callable interface depending on the
specific function. The library is built and tested using the following compilers:

* MCUXpresso IDE
* IAR Embedded Workbench
» Keil pyVision
For the MCUXpresso IDE, the library is delivered in the pclib.afile.
For the Kinetis Design Studio, the library is delivered in the pclib.afile.
For the IAR Embedded Workbench, the library is delivered in the pclib.a file.
For the Keil pVision, the library is delivered in the pclib./ib file.

The interfaces to the algorithms included in this library are combined into a single public interface include file, pclib.h. This is done
to lower the number of files required to be included in your application.

1.1.5 Library configuration

PCLIB for the ARM Cortex M7 core is written in C language or assembly language with C-callable interface depending on the
specific function. Some functions from this library are inline type, which are compiled together with project using this library. The
optimization level for inline function is usually defined by the specific compiler setting. It can cause an issue especially when high
optimization level is set. Therefore the optimization level for all inline assembly written functions is defined by compiler pragmas
using macros. The configuration header file RTCESL_cfg.his located in: specific library folderIMLIBlInclude. The optimization
level can be changed by modifying the macro value for specific compiler. In case of any change the library functionality is

not guaranteed.

1.1.6 Special issues

1. The equations describing the algorithms are symbolic. If there is positive 1, the number is the closest number to 1 that
the resolution of the used fractional type allows. If there are maximum or minimum values mentioned, check the range
allowed by the type of the particular function version.

2. The library functions that round the result (the API contains Rnd) round to nearest (half up).

3. This RTCESL requires the DSP extension for some saturation functions. If the core does not support the DSP extension
feature the assembler code of the RTCESL will not be buildable. For example the core1 of the LPC55s69 has no DSP
extension.

1.2 Library integration into project (MCUXpresso IDE)

This section provides a step-by-step guide on how to quickly and easily include PCLIB into any MCUXpresso SDK example or
new SDK project using MCUXpresso IDE. The SDK based project uses RTCESL from SDK package.
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High-speed functions execution suppport

Some RT (or other) platforms contain high-speed functions execution support by relocating all functions from the default Flash
memory location to the RAM location for much faster code access. The feature is important especially for devices with a slow Flash
interface. This section shows how to turn the RAM optimization feature support on and off.

1. In the MCUXpresso SDK project name node or on the left-hand side, click Properties or select Project > Properties from
the menu. A project properties dialog appears.

2. Expand the C/C++ Build node and select Settings. See Figure 1.
3. On the right-hand side, under the MCU C Compiler node, click the Preprocessor node. See Figure 1 .

-
[ Properties for twrkv31f120m_demo_apps_hello_world

E ey

Run/Debug Settings

(& Optimization

(& Debugging

(# Warnings

& Miscellaneous

(2 Architecture
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(2 Architecture & Headers
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DEBUG
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__MCUXPRESSO
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Figure 1. Defined symbols

4. On the right-hand side of the dialog, click the Add... icon located next to the Defined symbols (-D) title.
5. In the dialog that appears (see Figure 2), type the following:
* RAM_RELOCATION — to turn the RAM optimization feature support on
If the define is defined, all RTCEL functions are put to the RAM.

Defined symbols (-D)

RAM_RELOCATION I

Figure 2. Symbol definition

6. Click OK in the dialog.
7. Click OK in the main dialog.

The RAM_RELOCATION macro places the_raMrunc (RaM) atribute in front of each function declaration.
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Adding RTCESL component to project

The MCUXpresso SDK package is necessary to add any example or new project and RTCESL component. In case the

package has not been downloaded go to mcuxpresso.nxp.com, build the final MCUXpresso SDK package for required board and
download it.

After package is dowloaded, open the MCUXpresso IDE and drag&drop the SDK package in zip format to the Installed SDK

window of the MCUXpresso IDE. After SDK package is dropped the mesage accepting window appears as can be show in
following figure.

B mic UXpresso IDE - [u}
File Edit Navigate Search Project Configlools Run RTOS Analysis Wi Help
Hmid | @~ &~ A2 N F-O0-Q-i® =R W BRZESR pHERDR
@0 i Ribi-Fl-oT et Q iR
[ Project Bx.. 51 i Registers % Faults &, Periphera.. = O =7
8% 7 | |- 8
There are ne projects in your werkspace.
To add a project:
B Creste s new MCUXpresso IDE C/C+ + project.
@ import examples from SDK. ) MCUxpresso IDE SDK import - ul 'Y
% Create s project...
Dy Import projects.. ‘."_ j Areyou sure you want to import the following SDK in the
&Y common ' maupresso’ folder?
D:ASDK_2_10_0_HVP-KV31F120Mzzip
@ inst.. 2 [ Prop.. [2 Pny ]
=]
[ Installed SDKs
(1) Quickstart Panel £ (x)= Variables ®g Breakpoints = [ Toinstallan SDK, simply drag and lpresy
. A [Installed SDKs . Available Board
- MCUXpresso IDE - Quickstart Panel B | B
0t No t selected Name
project selecte
~+ Create or import a project
p— B New project...
?a
Import SDK le(s)..
@ impo example(s) [] Do not ask for confirmation on SDK Drag and Drop install
® Import project(s) from file system...
~ Build your project
@ o[E ;
o {1 MCUX workspace o

Figure 3. MCUXpresso IDE - imporing the SDK package to MCUXpresso IDE

Click OK to confirm the SDK package import. Find the Quickstart panel in left bottom part of the MCUXpresso IDE and click New
project... item or Import SDK example(s)... to add rtcesl component to the project.
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8 MCUX workspace - MCU¥presso IDE
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380 &

Invoke the new SDK project wizard

~ Build your project

@
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above or visit mcuxpresso.mxp.com to
obtain additional SDKs.

Please select an available board for your project.

[ Supported boards for device: MKV3TFS120012

vllx — >
Figure 4. MCUXpresso IDE - create new project or Import SDK example(s)
Then select your board, and clik Next button.
) 50K Wizard o x
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v
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Description:
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Name
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@

SDK Version

Manifest Ve... Location

(49420; 380 JE <Common>\SDK_2_10_0_HVP-KV:

< Back Finish Cancel

Figure 5. MCUXpresso IDE - selecting the board

Find the Middleware tab in the Components part of the window and click on the checkbox to be the rtcesl component ticked. Last

step is to click the Finish button and wait for project creating with all RTCESL libraries and include paths.

User Guide
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3 soK Wizard u] X
i, The source from the SDK will be copied into the workspace. If you want to use linked files, please unzip the 'SDK_2x_HVP-KV31F120M' SDK. VA &
. Configure the project
Project neme: | MKV31F31212_FirstProject] * | Project name suffix:

Use default location

C:\MCUX_workspace\MKV31F51212_FirstProject Browse..
Device Packages Board Project Type Project Options
® MKV3IFS12VLLIZ ® Defaut board files @CProject (O Cr+ Project SDK Debug Console (3 Semihost @) UART
O MKV31F312VLH12 O Empty board files [ CMSIS-Core

(O C Static Library () C++ Static Library Copy sources

[ Import other files

Components [F] Components selection summary B
Add or remove SDK software companents [ipesotiter |
Operating Systems [Drivers [CMSIS Drivers [ Utilities [Widdieware™ Board Components| Abstraction Layer| Software C =
Name Description Ve Info
Middleware B %l ®E £ Drivers
[opesotiter | £ Middlenere
£ Operating Systems
Name Description Version  Info = Software Component
[ £ FresMASTER £ Utilties
[ £ Memories.
[1 = Motor Cantrol
T rice! Real Time Control Embedded Software Library for CM... 110 | Real Time Gontrol Embedded Software Library far CNUF core
@ <Back Next> T

Figure 6. MCUXpresso IDE - selecting rtcesl component

Type the #include syntax into the code where you want to call the library functions. In the left-hand dialog, open the required .c
file. After the file opens, include the following lines into the #include section:

#include "mlib.h"
#include "pclib.h"

When you click the Build icon (hammer), the project is compiled without errors.

1.3 Library integration into project (Keil pVision)

This section provides a step-by-step guide on how to quickly and easily include PCLIB into an empty project or any
MCUXpresso SDK example or demo application projects using Keil pVision. This example uses the default installation path
(C:ANXP\RTCESL\CM7_RTCESL_4.7_KEIL). If you have a different installation path, use that path instead. If any MCUXpresso

SDK project is intended to use (for example hello_world project) go to Linking the files into the project chapter otherwise read
next chapter.

NXP pack installation for new project (without MCUXpresso SDK)

This example uses the NXP MKV58F1MO0xxx22 part, and the default installation path
(C:\NXP\RTCESL\CM7_RTCESL_4.7_KEIL) is supposed. If the compiler has never been used to create any NXP MCU-based
projects before, check whether the NXP MCU pack for the particular device is installed. Follow these steps:

1. Launch Keil yVision.

2. In the main menu, go to Project > Manage > Pack Installer....

3. In the left-hand dialog (under the Devices tab), expand the All Devices > Freescale (NXP) node.
4. Look for a line called "KVxx Series" and click it.
5

. In the right-hand dialog (under the Packs tab), expand the Device Specific node.

PCLIB User's Guide, Rev. 5, 01 November 2021
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6. Look for a node called "Keil::Kinetis_KVxx_DFP." If there are the Install or Update options, click the button to install/
update the package. See Figure 7.

7. When installed, the button has the "Up to date" title. Now close the Pack Installer.

18 Pack Installer - CKeil vS\VARMIPACK — - B =El =]
File Packs Window Help
[+l ‘ Device: Freescale - KVaox Series
4 Devices | Boards | T Packs | Examples | i
‘ Search: - X Pack Action Description
Device A =1~ Device Specific 1 Pack
I @ Atmel 257 Devices ||| | KeiKinetis Ko DFP | Tnstoll Freescale Kinetis Kixx Series Device Support
@ Fresscale 234 Devices El-Generic 10 Packs
%2 K Series 1 Device RM:CMSIS & Up io daic | CMSIS (Cortex Microcontroller Software Interface Standard)
42 K00 Series 2 Devices eilzARM_Compiler | & _Up to date | Keil ARM Compiler extensions
42 K10 Series 23 Devices eil:Jansson & Install___| Jansson is a C library for encoding, decoding and manipula
42 K20 Series 41 Devices eil:MDK-Middleware | & Update | Keil MDK-ARM Professional Middleware for ARM Cortex-M
42 K0 Series & Devices - Keil:MDK-Network DS | & Install Keil MDK-ARM Professional Middleware Dual-Stack IPud,/IP
42 k40 Series & Devices B-hwiPz P & Install IwIP is 2 light-weight implementation of the TCR/IP protoc
42 K50 Series 11 Devices - Micrium:RTOS & Install Micrium software components
42 K60 Series 18 Devices -Ory Package (CycloneTCP, CycloneSSL and Cyclon
42 K70 Series 4 Devices - wolfSSL::CyaSSL Light weight SSL/TLS and Crypt Library for Embedded Syste
42 K30 Series 2 Devices 1 - YOGITECH:ARSTL_AR. YOGITECH fRSTL Functional Safety EVAL Software Pack for
% KEdoo Series 6 Devices
4 Kb Series 11 Devices
4 Ko Series 54 Devices
% KMo Series 14 Devices
4 Ko Series 26 Devices
% Ko Series 8 Devices
% WPRISI6 Series |1 Device
P e ha | K |

Output 3 x

Refresh Pack descriptions

Update available for Keil:MDK-Middleware (installed: 6.4.0, available: 7.0.0-beta}

Ready [ [onme

New project (without MCUXpresso SDK)

To start working on an application, create a new project. If the project already exists and is opened, skip to the next section. Follow

these steps to create a new project:

1. Launch Keil pVision.

2. In the main menu, select Project > New pVision Project..., and the Create New Project dialog appears.

3. Navigate to the folder where you want to create the project, for example C:\KeilProjects\MyProject01. Type the name of the

project, for example MyProject01. Click Save. See Figure 8.

Create New Project

» Computer » System (C:) » KeilProjects » MyProject0l

File name:  MyProject0l

Save as type: IPro}act Files (*.uvproj; *.uvprojx)

= Browse Folders Save

Figure 8. Create New Project dialog

In the next dialog, select the Software Packs in the very first box.

Type " into the Search box, so that the device list is reduced to the devices.
Expand the node.

Click the MKV58F1M0xxx22 node, and then click OK. See Figure 9.

N o o &
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- =
Select Device for Target 'Target 1°.

ICPUl

Toolset
Search

=R

Vendor:
Device:

ISoﬂware Packs

Freescale
MKVSBF1MDooc22
ARM

Freescale

5% Ko Series

45 Kulx

A Kv3x

5 Ktk

2% Ksx
1 MKVSBFLMOceQ2
B MKVSBF51 20022
€

Description:

The Kinetis K\V5x family of MCL is a high-performance solution offering
exceptional precision, sensing and control targeting Industrial Maotor
Control, Industrial Drives and Automation and Power Conversion
applications

Built upen the ARM Cortex-M7 core running at 240 MHz with single
precision floating point unit.

It features high resolution pulse-width modulation (PVWM) with 312
picosecond resolution, 4x 12bit analogto-digital converters (ADCs)
sampling at 5 mega samples per second (M5/s), 3 AexCAN modules,
optional Ethemet Communications and comprehensive enablement
suite from Freescale and third-party resources including reference
designs, software libraries and motor configuration tools.

-

Figure 9. Select Device dialog

8. In the next dialog, expand the Device node, and tick the box next to the Startup node. See Figure 10.

9. Expand the CMSIS node, and tick the box next to the CORE node.

Software Component
=€ CMmsIS

# CORE

@ DSP

& RTOS (APT)

& CMSIS Driver
4 Compiler
= 4 Device

@ Startup
4 File System
4 Graphics
& Network
& use

Sel. Variant

I
=

MDK-Pro
MDK-Pro
MDK-Pro
MDK-Pro

Figure 10. Manage Run-Time Environment dialog

Version  Description

Cortex Microcontroller Software Interface Components

41.0 CMSIS-CORE for Cortex-M, 50000, and 5C300
145 CMSIS-DSP Library for Cortex-M, 50000, and SC300
10 CMSIS-RTOS API for Cortex-M, 50000, and 5C300

Unified Device Drivers compliant to CMSIS-Driver Specifications
ARM Compiler Software Extensions
Startup, System Setup
100 System Startup for Kinetis KV58 220MHz devices devices devices
64.0 File Access on various storage devices
5261 User Interface on graphical LCD displays
64.0 1P Metworking using Ethernet or Serial protocols

6.4.0 USB Communication with various device classes

10. Click OK, and a new project is created. The new project is now visible in the left-hand part of Keil yVision. See Figure 11.

PCLIB User's Guide, Rev. 5, 01 November 2021

User Guide

11747



NXP Semiconductors

Library

EE ChKailProjects\MyProject01\MyProjectdl.uvprojx - pVisicn

File Edit Wiew Project Flash Debug Peripherals Tool

= - NN .Y | |
L [ &2 f?| Target 1 Eﬁﬂ.|
Project 7 (&
=4 Project: MyProjectl
S-i Targetl
{J Scurce Group 1
& cmsis
= ’ Device
] startup_MKVS8F22.s (Startup)
] system_MEKVS8F22.c (Startup)
1 system_MEVS8F22.h (Startup)

Figure 11. Project

11. In the main menu, go to Project > Options for Target 'Target1'..., and a dialog appears.

12. Select the Target tab.
13. Select Not Used in the Floating Point Hardware option. See Figure 11.

Code Generation
ARM Compiler: |Llse default compiler version j

| Use Cross-Module Optimization
| Use MicroLIB [

Floating Point Hardware: -

Figure 12. FPU

High-speed functions execution support

Some RT (or other) platforms contain high-speed functions execution support by relocating all functions from the default Flash
memory location to the RAM location for much faster code access. The feature is important especially for devices with a slow Flash

interface. This section shows how to turn the RAM optimization feature support on and off.
1. In the main menu, go to Project > Options for Target 'Target1'..., and a dialog appears.
2. Select the C/C++ tab. See #unique_18.
3. In the Include Preprocessor Symbols text box, type the following:
* RAM_RELOCATION — to turn the RAM optimization feature support on
If the define is defined, all RTCEL functions are put to the RAM.
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Undefine: I
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I~ Optimize for Time [ Plain Charis Signed [T Thumb Mode
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Paths

Misc I
Controls

Compiler |- —cpu Cortex-M4fp -D__EVAL -g 00 -apcs=interwork
contral || C:\KeilProjects \MyProject01\RTE
string

Defaults

Figure 13. Preprocessor symbols

Click OK in the main dialog.

The RAM_RELOCATION macro places the attribute  ((section ("ram"))) atribute in front of each function declaration.

Linking the files into the project

To include the library files in the project, create groups and add them.

1.

Right-click the Target 1 node in the left-hand part of the Project tree, and select Add Group... from the menu. A new group
with the name New Group is added.

Click the newly created group, and press F2 to rename it to RTCESL.
Right-click the RTCESL node, and select Add Existing Files to Group 'RTCESL'... from the menu.

Navigate into the library installation folder C:\NXP\ARTCESL\CM7_RTCESL_4.7_KEIL\MLIB\Include, and select the mi/ib.h
file. If the file does not appear, set the Files of type filter to Text file. Click Add. See Figure 14.
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Lookin: | | Include j = £ Edv 1
Mame : Date modified il
i mlib.h 16.10.2014 9:19 iE |
| MLIB_Abs_F16.h 21.10.2014 9:45 W
| MLB_Abs_F32.h 16.10.2014 9:19

_ | MLB_Add_A32.h 16.10.2014 9:19

_ | MLIB_Add_F1&.h 16.10.2014 9:19

| MLIB_Add_F32.h 16.10.2014 9:19

_ | MLIB_Add4_F16.h 16.10.2014 9:19

| MLIB_Add4 _F32.h 16.10.2014 9:19

| MLIB_BiShift_F16.h 16.10.2014 2:19

| MLIB_BiShift_F32.h 16.10.2014 9:19

-

RALTR il F4E L

1 | n |

R W TG %

Add I
| Close |

File name: |mlib.h

Files of type: | Teut file ("bd; *h; *inc)

Figure 14. Adding .h files dialog

5. Navigate to the parent folder C:ANXP\RTCESL\CM7_RTCESL_4.7_KEIL\MLIB, and select the m/ib./ibfile. If the file does

not appear, set the Files of type filter to Library file. Click Add. See Figure 15.

Lookin: | . MLIB ~| & Bk E- |

MName Date modified Ty
/Include 20102014 15:37 Fi
|| MLIB.lib 16.10.2014 9:19 LI

4| (1

Add I
~| Close |

File name: |MLIE.Iib

Files of type: IIJblaryﬁIe {*lib)

Figure 15. Adding .lib files dialog

6. Navigate into the library installation folder C:\NXP\RTCESL\CM7_RTCESL_4.7_KEIL\PCLIB\Include, and select the
pclib.hfile. If the file does not appear, set the Files of type filter to Text file. Click Add.

7. Navigate to the parent folder C:\NXP\RTCESL\CM7_RTCESL_4.7_KEIL\PCLIB, and select the pclib.libfile. If the file does

not appear, set the Files of type filter to Library file. Click Add.

8. Now, all necessary files are in the project tree; see Figure 16. Click Close.
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| Project n B
=3 Project: MyProjectll
-3 Targetl
L J Source Group 1
B RTCESL
1 mlib.h
1 MLIE.lib
1 pelib.h
1 PCLIB.lib
& cmsis
= * Device

Figure 16. Project workspace

Library path setup

The following steps show the inclusion of all dependent modules.
1. In the main menu, go to Project > Options for Target 'Target1'..., and a dialog appears.
2. Select the C/C++ tab. See Figure 17.

3. In the Include Paths text box, type the following (if there are more paths, they must be separated by ';') or add by clicking
the ... button next to the text box:

* "C:\NXP\RTCESL\CM7_RTCESL_4.7_KEIL\MLIB\Include"
+ "C:\NXP\RTCESL\CM7_RTCESL_4.7_KEIL\PCLIB\Include"
4. Click OK.
5. Click OK in the main dialog.
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k] Options for Target ‘Target 1

Devicel Target | Oulpull Listingl User C/Ce+ |.&'sm I Linkerl Debug | Ltilities |

Symbals

Define: I
Undefine: I

— Language / Code Generation

I~ Stict ANSIC e
Optimization: lm I™ Enum Container abways int All'Wamings j'
I Optimize for Time ™ Plain Char is Signed = Thurmb Mode
I~ Split Load and Store Muttiple [~ Read-Cnly Position Independent [~ No Auto Includes
[~ One ELF Section per Function [~ Read-Write Postion Independert [~ C39 Mode

Include ||
Paths

Misc I
Controls

Compiler  |-¢ —cpu Cortex-M0+ -D__EVAL -g -00 —apcs=interwork
control [ C:\KeilProjects \MyProject01\RTE
string

Figure 17. Library path addition

Type the #include syntax into the code. Include the library into a source file. In the new project, it is necessary to create a
source file:

1. Right-click the Source Group 1 node, and Add New Item to Group 'Source Group 1'... from the menu.

2. Select the C File (.c) option, and type a name of the file into the Name box, for example 'main.c. See Figure 18.

: e e o o ompe
v o s or T

Create a new C source file and add it to the projec
C | CFile{c)

@ C++ File {.cpp)
\ﬂ Asm File ()

@ Header File (h)
é Text File (bd)
Qg\ Image File (%
1@ User Code Template

Type: I

Mame: I main.

Location: I C:\KeilProjects\MyProjectd1

Figure 18. Adding new source file dialog

3. Click Add, and a new source file is created and opened up.
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4. In the opened source file, include the following lines into the #include section, and create a main function:

#include "mlib.h"
#include "pclib.h"

int main (void)
{

while (1) ;
}

When you click the Build (F7) icon, the project will be compiled without errors.

1.4 Library integration into project (IAR Embedded Workbench)

This section provides a step-by-step guide on how to quickly and easily include the PCLIB into an empty project or any
MCUXpresso SDK example or demo application projects using IAR Embedded Workbench. This example uses the default
installation path (C:\NXP\RTCESL\CM7_RTCESL_4.7_IAR). If you have a different installation path, use that path instead. If any
MCUXpresso SDK project is intended to use (for example hello_world project) go to Linking the files into the project chapter
otherwise read next chapter.

New project (without MCUXpresso SDK)

This example uses the NXP MKV58F 1MO0xxx22 part, and the default installation path (C:\NXP\RTCESL\CM7_RTCESL_4.7_IAR)
is supposed. To start working on an application, create a new project. If the project already exists and is opened, skip to the next
section. Perform these steps to create a new project:

1. Launch IAR Embedded Workbench.

2. In the main menu, select Project > Create New Project... so that the "Create New Project" dialog appears. See Figure 19.

-~ =

Tool chain: | AFiM -

Froject templates:

[ asm -
[ C++

-+ DLIB [T, Co+ with exceptions and ATTI)
DLIB [C, Extended Embedded C++)

N el WOy R S RpppRpRp ey Y P

m m
00

Description:

C project uzing default tool settings inchuding an emply main.c file.

Figure 19. Create New Project dialog

3. Expand the C node in the tree, and select the "main" node. Click OK.

4. Navigate to the folder where you want to create the project, for example, C:\IARProjects\MyProject01. Type the name of the
project, for example, MyProject01. Click Save, and a new project is created. The new project is now visible in the left-hand
part of IAR Embedded Workbench. See Figure 20.
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Library

& IAR Embedded Workbench ID

File Edit View Project Simulator Tools Window Help

Nedd@ &SR o o

=,

Workspace

x L
main. c |

[ Debug

-

Files

Figure 20. New project

=lalMyProjectdl -Deb... |« | |
rmain.c
L@ 3 Output

int mainf()
{

return 0;

En O

! 1

In the main menu, go to Project > Options..., and a dialog appears.

In the Target tab, select the Device option, and click the button next to the dialog to select the MCU. In this example, select
NXP > KV5x > NXP MKV58F1MO0Oxxx22. Select None in the FPU option. Click OK. See Figure 21.

Cateqary:

Static Analysis
Runtime Checking
C/C++ Compiler
Assembler
QOutput Converter
Custom Build
Build Actions
Linker
Debuager
Simulator
Angel
CMSIS DAP
GDE Server
TAR. ROM-monitor
T4et/TTAG]et
J-Link/1-Trace
TI Stellaris
Macraigor
PE micro
RDI
ST-LIMK
Third-Party Driver
TI XDS

,

=)

Target | Qutput | Library Configuration | Library Options | MISRAC:200/ « | »

Processor varant
() Care Cortex-M7
@ Device  MXP MKVBEF1MEocc22
Endian mode Floating point settings
@ Little EPU - .
Eig
EE3Z [ registers
(@ BES

Adwvanced SIMD (NEON)

Figure 21. Options dialog

[ ok

] [ Cancel

High-speed functions execution suppport

Some RT (or other) platforms contain high-speed functions execution support by relocating all functions from the default Flash
memory location to the RAM location for much faster code access. The feature is important especially for devices with a slow Flash
interface. This section shows how to turn the RAM optimization feature support on and off.

1.

In the main menu, go to Project > Options..., and a dialog appears.
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2. In the left-hand side column, select C/C++ Compiler.

3. In the right-hand side of the dialog, click the Preprocessor tab (it can be hidden on the right; use the arrow icons
for navigation).

4. In the text box (in Defined symbols: (one per line)), type the following (See Figure 22):
* RAM_RELOCATION — to turn the RAM optimization feature support on
If the define is defined, all RTCEL functions are put to the RAM.

Options for node "MyProject01” | 2 |

Category: Factary Settings

General Options [T Multifile: Compilation

Static Analysis Dizeard Unused Publics
Runtime Checking

| Language 2 I Code I Optimizations I Output I List | Preprocessor L

Assembler
Output Converter [ lgnore standard include directories

CUT;Dm Build Additional include directories: (one per line)

Build Actions A

Linker E]

Debugger
Simulator
Angel
CMSIS DAP Preinclude file:

GDE Server E]
IAR. ROM-monitor
et/ TTAGIEt Defined symbols: {one per line)

Iink/3-Trace RAM_RELOCATION . [C]Preprocessor output to file
11 Stellaris Preserve comments

Macraigor il Generate Hine directives

PE micro

RDI

STALINK
Third-Party Driver
TIXDS

ok ] [ Cancel

L - |

Figure 22. Defined symbols

5. Click OK in the main dialog.

The RAM_RELOCATION macro places the  ramfunc atribute in front of each function declaration.

Library path variable
To make the library integration easier, create a variable that will hold the information about the library path.
1. In the main menu, go to Tools > Configure Custom Argument Variables..., and a dialog appears.

2. Click the New Group button, and another dialog appears. In this dialog, type the name of the group PATH, and click OK.
See Figure 23.
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1 ' Configure Custom Argument Variables | 29 |
Workspace | Global
Enable Group
Mew Group | 5= | E_OUD”'
Fiable...
MName: PATH _iable. .
_ete
oK l [ Cancel IF
prt...
Expand/Collapse All
[ Hide disabled groups
oK l l Cancel
Figure 23. New Group

3. Click on the newly created group, and click the Add Variable button. A dialog appears.
4. Type this name: RTCESL_LOC

5. To set up the value, look for the library by clicking the "..." button, or just type the installation path into the box:
C:\NXP\RTCESL\CM7_RTCESL_4.7_IAR. Click OK.

6. In the main dialog, click OK. See Figure 24.

# ' Configure Custom Argument Variables |£|
[ Workspace [ global |
[ pATH Disable Group
Add Variable =)
Name: | RTCESL_LOC |
Value: | C:\NXP\RTCESL_CM7_RTCESL_X.X_IAR | 0.

[ ok ][ cancel |
\— |

Figure 24. New variable

Linking the files into the project
To include the library files into the project, create groups and add them.

1. Go to the main menu Project > Add Group...

2. Type RTCESL, and click OK.

3. Click on the newly created node RTCESL, go to Project > Add Group..., and create a MLIB subgroup.
4. Click on the newly created node MLIB, and go to the main menu Project > Add Files... See Figure 26.
5

. Navigate into the library installation folder C:\NXP\RTCESL\CM7_RTCESL_4.7_IAR\MLIB\Include, and select the m/ib.h
file. (If the file does not appear, set the file-type filter to Source Files.) Click Open. See Figure 25.
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6. Navigate into the library installation folder C:\NXP\RTCESL\CM7_RTCESL_4.7_IAR\MLIB, and select the m/ib.afile. If the
file does not appear, set the file-type filter to Library / Object files. Click Open.

. B |
b System (C:) » NXP » RTCESL » CM7_RTCESL 4.3 IAR » MLIB » Include
B e
it Mame : Date modified Type
.| mlib.h 16.10.2015 9:38 H File
|| MLIB_Abs_F16.h 16.10.2015 9:38 H File
Figure 25. Add Files dialog

7. Click on the RTCESL node, go to Project > Add Group..., and create a PCLIB subgroup.
8. Click on the newly created node PCLIB, and go to the main menu Project > Add Files...

9. Navigate into the library installation folder C:\NXP\RTCESL\CM7_RTCESL_4.7_IAR\PCLIB\Include, and select the pclib.h
file. If the file does not appear, set the file-type filter to Source Files. Click Open.

10. Navigate into the library installation folder C:\NXP\RTCESL\CM7_RTCESL_4.7_IAR\PCLIB, and select the pclib.afile. If
the file does not appear, set the file-type filter to Library / Object files. Click Open.

11. Now you will see the files added in the workspace. See Figure 26.

Workspace x
[ Debug -

Files fn o
B  MyProjectd1 - Deb... v
-2 01 RTCESL
F&CaPcUB
| —DOFCLBA
| Y— &) polibh
a1 Co =T
F— O MLEB.a
L— [ mlibh
FrIdin. c *
=1 [ Qutput

Figure 26. Project workspace

Library path setup
1. In the main menu, go to Project > Options..., and a dialog appears.
2. In the left-hand column, select C/C++ Compiler.

3. In the right-hand part of the dialog, click on the Preprocessor tab (it can be hidden in the right; use the arrow icons
for navigation).

4. In the text box (at the Additional include directories title), type the following folder (using the created variable):
+ $RTCESL_LOCS$\MLIB\Include
+ $RTCESL_LOCS$\PCLIB\Include

5. Click OK in the main dialog. See Figure 27.
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Figure 27. Library path adition

ak ] [ Cancel

Type the #include syntax into the code. Include the library included into the main.cfile. In the workspace tree, double-click the
main.c file. After the main.cfile opens up, include the following lines into the #include section:

#include "mlib.h"
#include "pclib.h"

When you click the Make icon, the project will be compiled without errors.
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Chapter 2
Algorithms in detall

2.1 PCLIB_Ctrl2P2Z

The PCLIB_Ctrl2P2Z function calculates the compensation block for the controller, which consists of two poles and two zeroes.
The s-domain transfer function equation for two-pole two-zero control law is as follows:

Ml ZINs22)
5] ~ - Plis P2)

Figure 28.

where y[s] is the output, and x[s] is the input to the system. This control law has two poles (P1 and P2) and two zeroes (Z1 and
Z2). The value or the placement of these poles and zeroes in the bode plot affects the stability and performance of the control loop
and the system. The z-domain controller Gc¢(z) at sampling time Ts is expressed using the Tustin method as follows:

M _ (022 24b1z—Hb0)
A~ (lFa2z2-alz))

Figure 29.

A= al- ff]- 21— a2+ - z2= b0 - i} + b1 f]- 71+ b2 - o] 22
Figure 30.

where:
* y[t] = y[n] is the present output
* y[t] - z ' = y[n-1] is the previous output
* y[t] - z 2 = y[n-2] is the previous to previous output
* X[t] = x[n] is the present error
 x[t] - z ' = x[n-1] is the previous error
+ X[t] - z 2 = x[n-2] is the previous to previous error

* b0, b1, b2, a1, and a2 are the control coefficients and functions of Z1, Z2, P1, P2, and sampling time Ts.

Mnl=a2-yn—2]+al- Y n— 1+ b2-xn— 2]+ bl-xn— 1]+ b0 - x{n]
Figure 31.

For a proper use of this function, itis recommended to initialize the function's data by the PCLIB_Ctrl2P2ZInit function, before using
the function. This function clears the internal buffers of the 2P2Z controller. You must call this function when you want the 2P2Z
controller to be initialized. The init function must not be called together with PCLIB_Ctrl2P2Z, unless a periodic clearing of buffers
is required.

2.1.1 Available versions

The available versions of the PCLIB_Ctrl2P2ZInit function are shown in the following table:

Table 2. Init function versions

Function name Input type Parameters Result type

PCLIB_Ctrli2P2ZInit_F16 | frac16_t PCLIB_CTRL_2P2Z_T_F16 * void

Table continues on the next page...
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Table 2. Init function versions (continued)

Function name Input type Parameters Result type

The inputs are a 16-bit fractional initial value and a pointer to the controller's parameters structure.
It clears the internal delay parameter buffers of the controller.

The available versions of the PCLIB_Ctrl2P2Z function are shown in the following table:

Table 3. Function versions

Function name Input type Parameters Result type

PCLIB_Ctrl2P2Z_F16 |frac16_t PCLIB_CTRL_2P2Z_T_F16 * frac16_t

The error input is a 16-bit fractional value within the range <-1; 1). The parameters are pointed to by
an input pointer. The function returns a 16-bit fractional value in the range <-1 ; 1).

2.1.2 PCLIB_CTRL_2P2Z_T_F16

Variable name Type Description

f16CoeffBO frac16_t Control coefficient for the present error. The parameter is a 16-bit fractional value within
the range <-1; 1). Set by the user.

f16CoeffB1 frac16_t Control coefficient for the past error. The parameter is a 16-bit fractional value within the
range <-1; 1). Set by the user.

f16CoeffB2 frac16_t Control coefficient for the past to past error. The parameter is a 16-bit fractional value
within the range <-1 ; 1). Set by the user.

f16CoeffA1 frac16_t Control coefficient for the past result. The parameter is a 16-bit fractional value within the
range <-1; 1). Set by the user.

f16CoeffA2 frac16_t Control coefficient for the past to past result. The parameter is a 16-bit fractional value
within the range <-1 ; 1). Set by the user.

f16DelayX1 frac16_t Delay parameter for the past error. Controlled by the algorithm.
f16DelayX2 frac16_t Delay parameter for the past to past error. Controlled by the algorithm.
f16DelayY1 frac16_t Delay parameter for the past result. Controlled by the algorithm.
f16DelayY2 frac16_t Delay parameter for the past to past result. Controlled by the algorithm.

2.1.3 Declaration
The available PCLIB_Ctrl2P2Z functions have the following declarations:
void PCLIB Ctrl2P2ZInit F16(PCLIB CTRL 2P2Z T F16 *psParam)

fracl6 t PCLIB Ctrl2P2Z Fl6(fraclé t f16InErr, PCLIB CTRL 2P2Z T F16 *psParam)

2.1.4 Function use
The use of the PCLIB_Ctrl2P2ZInit_F16 and PCLIB_Ctrl2P2Z functions is shown in the following example:

#include "pclib.h"

static fracl6 t fl6Result, fl6InErr;
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static PCLIB_CTRL 2P2Z T F16 sParam;
void Isr(void);

void main (void)

{
fl6InErr = FRAC16(-0.4);
sParam.fl6CoeffB0 = FRAC16(0.1);
sParam.fl16CoeffBl = FRAC16(0.2);
sParam.f16CoeffB2 = FRAC16(0.15);
sParam.fl6CoeffAl = FRAC16(0.1);
sParam.fl6CoeffA2 = FRAC16(0.25);

PCLIB_Ctrl2P2ZInit F16 (&sParam) ;
}

/* Periodical function or interrupt */
void Isr ()

{
fl6Result = PCLIB Ctrl2P2Z Fl6(fl6InErr, &sParam);

2.2 PCLIB_Ctrl3P3Z

The PCLIB_CtrI3P3Z function calculates the compensation block for the controller, which consists of three poles and three zeroes.
The s-domain transfer function equation for the three-pole three-zero control law is as follows:

sl (ZINs—Z2Hs~73)
5] ~ (—PIys—P2K{s—P3)

Figure 32.

where y[s] is the output and x[s] is the input to the system. This control law has three poles (P1, P2, and P3) and three zeroes (Z1,
Z2, and Z3). The value or the placement of these poles and zeroes in the bode plot affects the stability and performance of the
control loop and the system. The z-domain controller Gc¢(z) at sampling time Ts is expressed using the Tustin method as follows:

A _ (b3z73+b2z 2+b1z—1+b0)
A~ (1ma3z-3-a2z2-alz1)

Figure 33.

WA= al-{f]- 21— a2 J{f]- 22— a3+ \i]- z 3= b0~ {e]+ b1- x{f]- 21+ b2 - X{1]- 22+ b3- 1] - 23
Figure 34.

where:
 y[t] = y[n] is the present output
* y[t] - z ' = y[n-1] is the previous output
+ y[t] - z 2 = y[n-2] is the previous to previous output
* y[t] - z 3 = y[n-3] is the previous to previous to previous output
» X[t] = x[n] is the present error
 X[t] - z' = x[n-1] is the previous error
« x[t] - "2 = x[n-2] is the previous to previous error

« X[t] - z 3 = x[n-3] is the previous to previous to previous error
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* b0, b1, b2, b3 a1, a2, and a3 are the control coefficients and functions of Z1, Z2, Z3, P1, P2, P3, and sampling time Ts.

Mnl=a3-yn—3]+a2-yn—2]+al-yn— 1+ b3-x{n—3]+ b2 x{n— 2]+ bl x{n— 1]+ b0 - x[n]

Figure 35.

For a proper use of this function, it is recommended to initialize the function's data by the PCLIB_Ctrl3P3ZInit function, before using
the function. This function clears the internal buffers of the 3P3Z controller. You must call this function when you want the 3P3Z
controller to be initialized. The init function must not be called together with PCLIB_Ctrl3P3Z, unless a periodic clearing of buffers

is required.

2.2.1 Available versions

The available versions of the PCLIB_Ctrl3P3ZInit function are shown in the following table:

Table 4. Init function versions

Function name

Input type

Parameters Result type

PCLIB_CtrI3P3ZInit_F16

frac16_t

PCLIB_CTRL_3P3Z_T_F16 * void

It clears the

The inputs are a 16-bit fractional initial value and a pointer to the controller's parameters structure.

internal delay parameter buffers of the controller.

The available versions of the PCLIB_Ctrl3P3Z function are shown in the following table:

Table 5. Function versions

Function name

Input type

Parameters Result type

PCLIB_CtrI3P3Z_F16

frac16_t

PCLIB_CTRL_3P3Z_T_F16 * frac16_t

The error input

an input pointer. The function returns a 16-bit fractional value in the range <-1 ; 1).

is a 16-bit fractional value within the range <-1 ; 1). The parameters are pointed to by

2.2.2 PCLIB_CTRL_3P3Z_T_F16

Variable name Input type Description

f16CoeffBO frac16_t Control coefficient for the present error. The parameter is a 16-bit fractional
value within the range <-1 ; 1). Set by the user.

f16CoeffB1 frac16_t Control coefficient for the past error. The parameter is a 16-bit fractional
value within the range <-1 ; 1). Set by the user.

f16CoeffB2 frac16_t Control coefficient for the past to past error. The parameter is a 16-bit
fractional value within the range <-1 ; 1). Set by the user.

f16CoeffB3 frac16_t Control coefficient for the past to past to past error. The parameter is a
16-bit fractional value within the range <-1; 1). Set by the user.

f16CoeffA1 frac16_t Control coefficient for the past result. The parameter is a 16-bit fractional
value within the range <-1 ; 1). Set by the user.

f16CoeffA2 frac16_t Control coefficient for the past to past result. The parameter is a 16-bit
fractional value within the range <-1 ; 1). Set by the user.

f16CoeffA3 frac16_t Control coefficient for the past to past to past result. The parameter is a

16-bit fractional value within the range <-1; 1). Set by the user.

Table continues on the next page...
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Table continued from the previous page...

Variable name Input type Description

f16DelayX1 frac16_t Delay parameter for the past error. Controlled by the algorithm.

f16DelayX2 frac16_t Delay parameter for the past to past error. Controlled by the algorithm.

f16DelayX3 frac16_t Delay parameter for the past to past to past error. Controlled by the
algorithm.

f16DelayY1 frac16_t Delay parameter for the past result. Controlled by the algorithm.

f16DelayY2 frac16_t Delay parameter for the past to past result. Controlled by the algorithm.

f16DelayY3 frac16_t Delay parameter for the past to past to past result. Controlled by the
algorithm.

2.2.3 Declaration

The available PCLIB_CtrI3P3Z functions have the following declarations:

void PCLIB Ctrl3P3zZInit F16(PCLIB CTRL 3P3Z T F16 *psParam)
fracl6_t PCLIB_Ctrl3P3Z Fl6(fracl6_t fl6InErr, PCLIB_CTRL 3P3Z T F16 *psParam)

2.2.4 Function use
The use of the PCLIB_Ctrl3P3ZInit_F16 and PCLIB_CtrI3P3Z functions is shown in the following example:

{

}

{

#include "pclib.h"

static fracl6_t fl6Result,
static PCLIB_CTRL_3P3Z T_F1l6 sParam;

void Isr (void) ;

void main (void)

f16InErr = FRACL16(-0.4);

sParam.
sParam.
sParam.
sParam.
sParam.
sParam.
sParam.

PCLIB_Ctrl3P3ZInit F16 (&sParam);

void Isr ()

£f16CoeffBO
fl16CoeffB1
f16CoeffB2
f16CoeffB3
fl6CoeffAl
f16CoeffA2
f16CoeffA3

FRAC16 (0.
L2) i
FRAC16 (0.
FRAC16 (0.
FRAC16 (0.
.25);
c39)) 2

FRAC16 (0

FRAC16 (0
FRAC16 (0

/* Periodical function or interrupt */

fl6Result = PCLIB Ctrl3P3Z Fl6(fl6InErr, &sParam);

f16InErr;

1);

15);
12) ;
1);
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2.3 PCLIB_CtrlPI

The PCLIB_CtrlPI function calculates the Proportional-Integral (PI) compensation block for any given control system in power-
control and motor-control applications. The integral output of the controller is also limited, and the limit values (IntegralUpperLimit
and IntegralLowerLimit) are defined by the user. The controller output is also limited, and the limit values (UpperLimit and
LowerLimit) are defined by the user. The integral state is limited by the controller limits in the same way as the controller output.

The PI algorithm in the continuous time domain is expressed as follows:

t
y(t)=Kp-e(t)+JKi-e(t)-dl

0

Figure 36.

The above equation can be rewritten into the discrete time domain by approximating the integral term. The integral term is
approximated by the Backward Euler method, also known as backward rectangular or right-hand approximation, as follows:

ym=yn-N)+Ki-Ts-en)

Figure 37.

The discrete time domain representation of the PI algorithms is as follows:

y(n)=Kp-e(n)+yIn* D)+ Ki-Ts-e(n)

Figure 38.

where:
* e(n) is the input error
* y(n) is the controller output
» Kp is the proportional gain
+ Kiis the integral gain
* yi(n-1) is the previous integral output
* Tsis the sampling time

Rewritten as follows:

Wn)=Kp-en)+yn=1N+K;-en)

Figure 39.

K;=Ki-Ts

Figure 40.

For a proper use of this function, it is recommended to initialize the function's data by the PCLIB_CtrIPlInit functions, before using
this function. This function clears the internal buffers of a Pl controller. You must call this function when you want the PI controller
to be initialized. The init function must not be called together with PCLIB_CtrlPI, unless a periodic clearing of buffers is required.
2.3.1 Available versions

The available versions of the PCLIB_CtrIPlInit function are shown in the following table:
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Table 6. Init function versions

Function name Input type Parameters Result type

PCLIB_CtrIPIInit_F16 frac16_t PCLIB_CTRL_PI_T_F16 * void

The inputs are a 16-bit fractional initial value and a pointer to the controller's parameters structure.
It clears the internal integral accumulator buffer.

The available versions of the PCLIB_CtrlPI function are shown in the following table:

Table 7. Function versions

Function name Input type Parameters Result type

PCLIB_CtrIPI_F16 frac16_t PCLIB_CTRL_PI_T_F16 * frac16_t

The error input is a 16-bit fractional value within the range <-1 ; 1). The parameters are
pointed to by an input pointer. The function returns a 16-bit fractional value in the range
<f16LowerLimit ; f16UpperLimit>.

2.3.2 PCLIB_CTRL_PI_T_F16

Variable name Input type Description

f16Kp frac16_t Proportional gain. The parameter is a 16-bit fractional value within the range <-1; 1).
Set by the user.

f16Ki frac16_t Integral gain. The parameter is a 16-bit fractional value within the range <-1; 1). Set
by the user.

f16PreviousintegralOu | frac16_t Internal integral accumulator. Controlled by the algorithm.

tput

f16IntegralUpperLimit | frac16_t Upper limit of the the integral accumulator. These parameters must be greater than

f16IntegralLowerLimit. Set by the user.

f16IntegralLowerLimit |frac16_t Lower limit of the the integral accumulator. These parameters must be lower than
f16IntegralUpperLimit. Set by the user.

f16UpperLimit frac16_t Upper limit of the the controller's output. These parameters must be greater than
f16LowerLimit. Set by the user.

f16LowerLimit frac16_t Lower limit of the the controller's output. These parameters must be lower than
f16UpperLimit. Set by the user.

2.3.3 Declaration

The available PCLIB_CtrlPI functions have the following declarations:

void PCLIB CtrlPIInit F16(PCLIB CTRL PI T F16 *psParam)
fracl6 t PCLIB CtrlPI F16(fraclé t f16InErr, PCLIB CTRL PI T F16 *psParam)
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2.3.4 Function use
The use of the PCLIB_CtrlPlInit_F16 and PCLIB_CtrlPI functions is shown in the following example:

#include "pclib.h"

static fracl6 t fl6Result, fl6InErr;
static PCLIB CTRL PI T F16 sParam;

void Isr(void) ;

void main (void)

{
fl16InErr = FRAC16(-0.4);
sParam. f16Kp FRAC16(0.1);
sParam.fl16Ki = FRAC16(0.2);
sParam.fléIntegralUpperLimit = FRAC16(0.9);
sParam.fléIntegrallowerLimit = FRAC16(-0.9);
sParam.fl6UpperLimit = FRAC16(0.9);
sParam.fl6LowerLimit = FRAC16(-0.9);

PCLIB CtrlPIInit F16 (&psParam);

/* Periodical function or interrupt */
void Isr()
{
fl6Result = PCLIB CtrlPI F16(fl6InErr, &sParam);

2.4 PCLIB_CtrIPlandLPFilter

The PCLIB_CtrIPlandLPFilter function calculates the Proportional-Integral (PI) compensation block, along with the low-pass filter.
The low-pass filter's pole and zero are placed at much higher frequency to compensate for the output capacitor ESR. It can be
represented as follows:

Oupu=(K p+ &) (25

Figure 41.

It increases the system performance even at the high frequency (in bode plot frequency domain) of system operations. This is
equivalent to:

sl (sZIXs—22)

As] — (s—PINs—P2)

Figure 42.

where y[s] is the output, and x[s] is the input to the system. This control law has two poles (P1 and P2) and two zeroes (Z1 and
Z2). The value or the placement of these poles and zeroes in the bode plot influence the stability and performance of the control
loop and the system. The z-domain controller Ge(z) at sampling time Ts is expressed using the Tustin method as follows:

M (B2 2+blzHb0)
A~ (Fa2z2-alz )

Figure 43.
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WA —al-y{f]- 21— a2+ 3{f]- 22 = b0 - A{f]+ b1 x{]- 21+ b2+ x{f]- 22

Figure 44.

where:
 y[t] = y[n] is the present output
* y[t] - z ' = y[n-1] is the previous output
* y[t] - "2 = y[n-2] is the previous to previous output
* X[t] = x[n] is the present error
+ x[t] - "' = x[n-1] is the previous error
« X[t] - z 2 = x[n-2] is the previous to previous error

* b0, b1, b2, a1, and a2 are the control coefficients and functions of Z1, Z2, P1, P2, and sampling time Ts.

Mnl=al-n—1]+a2- yn—2]+b0-x{n]+bl-x{n— 1]+ 52 -x{n— 2]
Figure 45.

For a proper use of this function, it is recommended to initialize the function's data by the PCLIB_CtrIPlandLPInit functions, before
using the function. This function clears the internal buffers of the PlandLP controller. You must call this function when you want the
PlandLP controller to be initialized. The init function must not be called together with PCLIB_CtrlPlandLPFilter, unless a periodic
clearing of buffers is required.

2.4.1 Available versions

The available versions of the PCLIB_CtrIPlandLPInit function are shown in the following table:

Table 8. Init function versions

Function name Input type Parameters Result type

PCLIB_CtrIPlandLPInit_F1 | frac16_t PCLIB_CTRL_PI_LP_T_F16 * void
6

The inputs are a 16-bit fractional initial value and a pointer to the controller's parameters structure.
It clears the internal delay parameter buffers of the controller.

The available versions of the PCLIB_CtrIPlandLPFilter function are shown in the following table:

Table 9. Function versions

Function name Input type Parameters Result type

PCLIB_CtrIPlandLP_F1 | frac16_t PCLIB_CTRL_PI_LP_T_F16 * frac16_t
6

The error input is a 16-bit fractional value within the range <-1 ; 1). The parameters are pointed to by
an input pointer. The function returns a 16-bit fractional value in the range <-1 ; 1).

24.2 PCLIB_CTRL_PI_LP_T_F16

Variable name Input type Description

f16CoeffBO frac16_t Control coefficient for the present error. The parameter is a 16-bit fractional
value within the range <-1 ; 1). Set by the user.

Table continues on the next page...
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Table continued from the previous page...

Variable name Input type Description

f16CoeffB1 frac16_t Control coefficient for the past error. The parameter is a 16-bit fractional
value within the range <-1 ; 1). Set by the user.

f16CoeffB2 frac16_t Control coefficient for the past to past error. The parameter is a 16-bit
fractional value within the range <-1 ; 1). Set by the user.

f16CoeffA1 frac16_t Control coefficient for the past result. The parameter is a 16-bit fractional
value within the range <-1 ; 1). Set by the user.

f16CoeffA2 frac16_t Control coefficient for the past to past result. The parameter is a 16-bit
fractional value within the range <-1 ; 1). Set by the user.

f16DelayX1 frac16_t Delay parameter for the past error. Controlled by the algorithm.
f16DelayX2 frac16_t Delay parameter for the past to past error. Controlled by the algorithm.
f16DelayY1 frac16_t Delay parameter for the past result. Controlled by the algorithm.
f16DelayY2 frac16_t Delay parameter for the past to past result. Controlled by the algorithm.

2.4.3 Declaration
The available PCLIB_CtrIPlandLPFilter functions have the following declarations:
void PCLIB CtrlPIandLPInit F16 (PCLIB CTRL PI LP T F16 *psParam)

fracl6_t PCLIB_CtrlPIandLP_F1l6 (fracl6e t fl6InErr, PCLIB CTRL PI LP T F16 *psParam)

2.4.4 Function use
The use of the PCLIB_CtrIPlandLPInit_F16 and PCLIB_CtrIPlandLPFilter functions is shown in the following example:

#include "pclib.h"

static fraclé t fl6Result, fl6InErr;
static PCLIB CTRL PI LP T F16 sParam;

void Isr (void) ;

void main (void)

{
fl6InErr = FRAC16(-0.4);
sParam.fl6CoeffB0 = FRAC16 (0.
sParam.fl16CoeffBl = FRAC16 (0.
sParam.fl6CoeffB2 = FRAC16 (0.1
sParam.fl6CoeffAl = FRAC16 (0.1
sParam.fl16CoeffA2 = FRAC16(0.25);

N
- 1 - —
— N S

PCLIB CtrlPIandLPInit F16 (&sParam);
}

/* Periodical function or interrupt */
void Isr()

{
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fl6Result = PCLIB CtrlPIandLP F16(fl6InErr, &sParam);

2.5 PCLIB_CtrlPID

The PCLIB_CtrIPID function calculates the Proportional-Integral-Derivative (PID) algorithm, according to the proportional (Kp),

integral (Ki), and differential (Kd) coefficients. The controller output is limited, and you can define the limit values.

The PID algorithm in the continuous time domain is expressed as follows:

t
Y(f)zKp'dt)+J(Ki- ef)-d)+Kd- %
0

Figure 46.

where:
» e(t) is the input error in the continuous time domain
 y(t) is the controller output in the continuous time domain
» Kp is the proportional coefficient
« Kiis the integral coefficient
* Kd is the differential coefficient

It can be rewritten as:

Kp-e)=Kp-x(t)

Figure 47.
t .
Kije(t) -di =725 x)
0
Figure 48.
Kd-“2 — kd-(1-z1)-x(0)
Figure 49.
(K prKitKdys(tyH(-K p-2Kdyx(tyz— 1+ Kdx(ty=2
WO = =1
Figure 50.
It can be further simplified as:
Kp+Ki+Kd=KA
-Kp-2Ky=KB
Kd=KC
therefore:
y(l) _ Kax(tyrK bxl(i)rrlHK ex(tyz2
Figure 51.
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WO=yt)-z 1+ Ka-x(t)+ Kb-x(t)-z 1+ Kc- x(t)- 2
Figure 52.

Mnl=Un— 1]+ Ka-xn]+ Kb-xn— 1]+ Kc-x{n—2]

Figure 53.

where:

* y(t) = y[n] is the present output

 y(t) - z" = y[n-1] is the previous output

» Xx(t) = x[n] is the present error

+ x(t) - z' = x[n-1] is the previous error

+ x(t) - z 2 = x[n-2] is the previous to previous error
For a proper use of this function, it is recommended to initialize the function's data by the PCLIB_CtrIPIDInit functions, before
using this function. This function clears the internal buffers of the PID controller. You must call this function when you want the PID
controller to be initialized. The init function must not be called together with PCLIB_CtrIPID, unless a periodic clearing of buffers
is required.
2.5.1 Available versions

The available versions of the PCLIB_CtrIPIDInit function are shown in the following table:

Table 10. Init function versions

Function name Input type Parameters Result type

PCLIB_CtrIPIDInit_F16 frac16_t PCLIB_CTRL_PID_T_F16 * void

The inputs are a 16-bit fractional initial value and a pointer to the controller parameters' structure.
It clears the internal delay parameter buffers of the controller.

The available versions of the PCLIB_CtrlPID function are shown in the following table:

Table 11. Function versions

Function name Input type Parameters Result type

PCLIB_CtrIPID_F16 frac16_t PCLIB_CTRL_PID_T_F16 * frac16_t

The error input is a 16-bit fractional value within the range <-1; 1). The parameters are
pointed to by an input pointer. The function returns a 16-bit fractional value in the range
<f16LowerLimit ; f16UpperLimit>.

2.5.2 PCLIB_CTRL_PID_T_F16

Variable name Input type Description

f16Ka frac16_t Control coefficient for the present error. The parameter is a 16-bit fractional
value within the range <-1 ; 1). Set by the user.

f16Kb frac16_t Control coefficient for the past error. The parameter is a 16-bit fractional
value within the range <-1; 1). Set by the user.

Table continues on the next page...
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Variable name Input type Description

f16Kc

frac16_t Control coefficient for the past to past error. The parameter is a 16-bit

fractional value within the range <-1 ; 1). Set by the user.

f16DelayX1 frac16_t Delay parameter for the past error. Controlled by the algorithm.

f16DelayX2 frac16_t Delay parameter for the past to past error. Controlled by the algorithm.

f16DelayY1 frac16_t Delay parameter for the past result. Controlled by the algorithm.

f16UpperLimit frac16_t Upper limit of the controller's output. This parameter must be greater than
f16LowerLimit. Set by the user.

f16LowerLimit frac16_t Lower limit of the controller's output. This parameter must be lower than

f16UpperLimit. Set by the user.

2.5.3 Declaration

The available PCLIB_CtrIPID functions have the following declarations:

void PCLIB CtrlPIDInit F16(PCLIB CTRL PID T F16 *psParam)

fracl6_t PCLIB_CtrlPID Fl6(fracl6_t fl6InErr,

2.5.4 Function use

The use of the PCLIB_CtrlPIDInit_F16 and PCLIB_CtrlPID functions is shown in the following example:

PCLIB_CTRL_PID T F16 *psParam)

#include "pclib.h"

static fracl6 t fl6Result, fl6InErr;
static PCLIB_CTRL_PID T F16 sParam;

void Isr (void) ;

void main (void)

{
f16InErr = FRAC16(-0.4);
sParam.fl6Ka = FRAC16(O 1);
sParam.f16Kb = FRAC16 (0. )
sParam.fl6Kc = FRAC16(0.15);
sParam.fl6UpperLimit = RAC16(O 9) 2

sParam.fl6LowerLimit = FRAC16(-0.9);

PCLIB CtrlPIDInit F16 (&sParam);

/* Periodical function or interrupt */
void Isr()
{
fl6Result = PCLIB CtrlPID F16(fl6InErr, &sParam);
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Library types

A.1 bool_t

The bool_t type is a logical 16-bit type. It is able to store the boolean variables with two states: TRUE (1) or FALSE (0). Its definition

is as follows:
typedef unsigned short bool t;

The following figure shows the way in which the data is stored by this type:

Table 12. Data storage

15 14 13 12 11 10 9 8 7 6 0
Value Unused Logi
cal
TRUE O lolo|o|o0o|O0O|O]|O]oO]|oO 1
0 0 0
FALSE 0 0 0 0 0 0 0 0 0 0 0
0 0 0

To store a logical value as bool_t, use the FALSE or TRUE macros.

A.2 uint8_t

The uint8_t type is an unsigned 8-bit integer type. It is able to store the variables within the range <0 ; 255>. Its definition is

as follows:
typedef unsigned char uint8_t;

The following figure shows the way in which the data is stored by this type:

Table 13. Data storage

Value Integer

255 1 1 1 1 1

Table continues on the next page...
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Table 13. Data storage (continued)
11 0 0 0 1 1
0
124 0 1 1 1 0
7
159 1 0 0 1 1
9
A.3 uint16_t

The uint16_t type is an unsigned 16-bit integer type. It is able to store the variables within the range <0 ; 65535>. Its definition is

as follows:

typedef unsigned short uintlé6 t;

The following figure shows the way in which the data is stored by this type:

Table 14. Data storage

15 14 13 12 1" 10 7 0
Value Integer

65535 1 1 1 1 1 1 1 1
F

5 0 0 0 0 0 0 0 1
0

15518 0 0 1 1 1 1 1 0
3

40768 1 0 0 1 1 1 0 0
9
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The uint32_t type is an unsigned 32-bit integer type. Itis able to store the variables within the range <0 ; 4294967295>. Its definition

is as follows:

typedef unsigned long uint32 t;

The following figure shows the way in which the data is stored by this type:

Table 15. Data storage

31 24 23 16 15 7 0
Value Integer
4294967295 F F F F
2147483648 8 0 0 0
55977296 0 3 2 0
3451051828 C D D 4
A.5 int8_t

The int8_t type is a signed 8-bit integer type. It is able to store the variables within the range <-128 ; 127>. Its definition is as follows:

typedef char int8 t;

The following figure shows the way in which the data is stored by this type:

Table 16. Data storage

Table continues on the next page...
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Value Sign Integer

127 0 1 1 1 1
7

-128 1 0 0 0 0
8

60 0 0 1 1 0
3
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Table 16. Data storage (continued)

-97 1 0 0 1 1 1 1 1

A.6 int16_t

The int16_t type is a signed 16-bit integer type. It is able to store the variables within the range <-32768 ; 32767>. Its definition is
as follows:

typedef short intl6 t;

The following figure shows the way in which the data is stored by this type:

Table 17. Data storage

15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0
Value Sign Integer
32767 0 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
7 F F F
-32768 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
8 0 0 0
15518 0 0 1 1 1 1 0 0 1 0 0 1 1 1 1 0
3 Cc 9 E
-24768 1 0 0 1 1 1 1 1 0 1 0 0 0 0 0 0
9 F 4 0
A.7 int32_t

The int32_t type is a signed 32-bit integer type. It is able to store the variables within the range <-2147483648 ; 2147483647>. Its
definition is as follows:

typedef long int32 t;

The following figure shows the way in which the data is stored by this type:

Table 18. Data storage

Table continues on the next page...
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Table 18. Data storage (continued)
31 24 23 16 15 8 7 0
Value S Integer
2147483647 7 F F F F F F F
-2147483648 8 0 0 0 0 0 0 0
55977296 0 3 5 6 2 5 5 0
-843915468 C D B 2 D F 3 4
A.8 frac8_t

The frac8_t type is a signed 8-bit fractional type. It is able to store the variables within the range <-1 ; 1). Its definition is as follows:
typedef char frac8 t;

The following figure shows the way in which the data is stored by this type:

Table 19. Data storage

7 6 5 4 3 2 1 0
Value Sign Fractional
0.99219 0 1 1 1 1 1 1 1
7 F
-1.0 1 0 0 0 0 0 0 0
8 0
0.46875 0 0 1 1 1 1 0 0
3 C
-0.75781 1 0 0 1 1 1 1 1
9 F

To store a real number as frac8_t, use the FRAC8 macro.
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A.9 frac16_t

The frac16_t type is a signed 16-bit fractional type. It is able to store the variables within the range <-1 ; 1). Its definition is
as follows:

typedef short fraclé6 t;

The following figure shows the way in which the data is stored by this type:

Table 20. Data storage

%5 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0
Value Sign Fractional
0.99997 0 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
7 F F F
-1.0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
8 0 0 0
0.47357 0 0 1 1 1 1 0 0 1 0 0 1 1 1 1 0
3 Cc 9 E
-0.75586 1 0 0 1 1 1 1 1 0 1 0 0 0 0 0 0
9 F 4 0

To store a real number as frac16_t, use the FRAC16 macro.

A.10 frac32_t

The frac32_t type is a signed 32-bit fractional type. It is able to store the variables within the range <-1; 1). Its definition is
as follows:

typedef long frac32 t;

The following figure shows the way in which the data is stored by this type:

Table 21. Data storage

31 24 23 16 15 8 7 0

Value S Fractional

0.9999999995

~
M

F F F F F F

Table continues on the next page...
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Table 21. Data storage (continued)

Library types

-1.0 8 0 0 0 0
0.02606645970 0 3 5 6 2
-0.3929787632 Cc D B 2 D

To store a real number as frac32_t, use the FRAC32 macro.

A.11 acc16_t

The acc16_t type is a signed 16-bit fractional type. It is able to store the variables within the range <-256 ; 256). Its definition is

as follows:
typedef short accl6 t;

The following figure shows the way in which the data is stored by this type:

Table 22. Data storage

15 14 13 12 11 10 9 8 7 6 3
Value Sign Integer Fractional

255.9921875 0 1 1 1 1 1 1 1 1 1 1
7 F F

-256.0 1 0 0 0 0 0 0 0 0 0 0
8 0 0

1.0 0 0 0 0 0 0 0 0 1 0 0
0 0 8

-1.0 1 1 1 1 1 1 1 1 1 0 0
F F 8

13.7890625 0 0 0 0 0 1 1 0 1 1 0
0 6 E

-89.71875 1t /1]0|1|o0o|l0|1]1]|]0]o0O 0
D 3 2
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To store a real number as acc16_t, use the ACC16 macro.

A.12 acc32_t

Library types

The acc32_t type is a signed 32-bit accumulator type. It is able to store the variables within the range <-65536 ; 65536). Its

definition is as follows:

typedef long acc32 t;

The following figure shows the way in which the data is stored by this type:

Table 23. Data storage

31 24 23 16 15 8 7 0

Value S Integer Fractional
65535.999969 7 F F F F
-65536.0 8 0 0 0 0
1.0 0 0 0 8 0

-1.0 F F F 8 0
23.789734 0 0 B E 1
-1171.306793 F B 6 5 B

To store a real number as acc32_t, use the ACC32 macro.

A.13 FALSE

The FALSE macro serves to write a correct value standing for the logical FALSE value of the bool_t type. Its definition is as follows:

#define FALSE ((bool t)0)

#include "mlib.h"

static bool t bval;

void main (void)
{

bVal = FALSE;
}

/* bvVal = FALSE */
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Library types

A.14 TRUE

The TRUE macro serves to write a correct value standing for the logical TRUE value of the bool_t type. Its definition is as follows:

#define TRUE ((bool t)1)

#include "mlib.h"
static bool t bval;
void main (void)

{
bval = TRUE; /* bval = TRUE */

A.15 FRACS8

The FRAC8 macro serves to convert a real number to the frac8_t type. Its definition is as follows:

#define FRAC8 (x) ((frac8 t) ((x) < 0.9921875 ? ((x) >= -1 ? (x)*0x80 : 0x80) : O0x7F))

The input is multiplied by 128 (=27). The output is limited to the range <0x80 ; 0x7F>, which corresponds to <-1.0 ; 1.0-27>.

#include "mlib.h"
static frac8_t f8val;
void main (void)

{
f8val = FRAC8(0.187); /* f8Val = 0.187 */

A.16 FRAC16

The FRAC16 macro serves to convert a real number to the frac16_t type. Its definition is as follows:
#define FRAC16 (x) ((fracl6 t) ((x) < 0.999969482421875 2 ((x) >= -1 2 (x)*0x8000 : 0x8000) : Ox7FFF))

The input is multiplied by 32768 (=215). The output is limited to the range <0x8000 ; 0x7FFF>, which corresponds to
<-1.0; 1.0-21%>,

#include "mlib.h"
static fracle6_t flé6vVal;
void main (void)

{
fl6val = FRAC16(0.736); /* fleval = 0.736 */
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A.17 FRAC32
The FRAC32 macro serves to convert a real number to the frac32_t type. Its definition is as follows:
#define FRAC32 (x) ((frac32 t) ((x) < 1 2 ((x) >= -1 ? (x)*0x80000000 : 0x80000000) : Ox7FFFFFEF))

The inputis multiplied by 2147483648 (=231). The output is limited to the range <0x80000000 ; 0x7FFFFFFF>, which corresponds
to <-1.0; 1.0-2731>.

#include "mlib.h"
static frac32 t f32Val;
void main (void)

{
£32val = FRAC32(-0.1735667) ; /* £32val = -0.1735667 */

A.18 ACC16

The ACC16 macro serves to convert a real number to the acc16_t type. Its definition is as follows:
#define ACCL6(x) ((accl6_t) ((x) < 255.9921875 2 ((x) >= -256 2 (x)*0x80 : 0x8000) : Ox7FFF))

The input is multiplied by 128 (=27). The output is limited to the range <0x8000 ; 0x7FFF> that corresponds to
<-256.0 ; 255.9921875>.

#include "mlib.h"
static accl6_t aléval;
void main (void)

{
aléval = ACC16(19.45627) ; /* alé6val = 19.45627 */

A.19 ACC32

The ACC32 macro serves to convert a real number to the acc32_t type. Its definition is as follows:

#define ACC32 (x) ((acc32 t) ((x) < 65535.999969482421875 ? ((x) >= -65536 ? (x)*0x8000 : 0x80000000)
0x7FFFFFFF))

The input is multiplied by 32768 (=219). The output is limited to the range <0x80000000 ; 0x7FFFFFFF>, which corresponds to
<-65536.0 ; 65536.0-21%>,

#include "mlib.h"
static acc32_t a32val;

void main (void)
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a32Val = ACC32(-13.654437); /* a32val = -13.654437 */
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